Pay in installments of $237.11 with
,
and
Shipping Estimate
USA
- USA
- CAN
- USA
- CAN
Ships within 48 hours · Estimated delivery Oct 12 - Oct 17
For Your Every Summer RSVP, with Code: SUMMER15
Description
Cambium Networks Cnmatrix Ex2028-P 24x PoeCambium Networks EX2028P Gestionado L2 Gigabit Ethernet (10 100 1000) Energa sobre Ethernet (PoE) 1U Gris Cambium Networks EX2028P, Gestionado, L2, Gigabit Ethernet (10 100 1000), Energa sobre Ethernet (PoE), Montaje en rack, 1U Puntos clave del producto Gestionado L2 Administacin basada en web SNMP v1, v2, and v3, SSH 1. 5 and 2. 0, RFC 4252: SSH, RFC 4253: SSH, RFC 4254: SSH, RFC 4251: SSH, RFC 4716: SECSH, RFC 4419, SSL 3. 0, RFC 2246, RFC 2818,

Shipping Notes
- Free Standard Shipping on $100+ Orders to the USA.
- Except Preorder products are shipped in 48 hours.
- Delivery to the USA:
- Standard Shipping : 3-10 business days
- If time is of the essence, please consider selecting expedited delivery for faster service.
Exchange/Return Notes
- We offer a 30-day return/exchange service after receiving.
- Final sale items are not eligible for returns or exchanges.
- To process your return/exchange, please contact us at [email protected]
- Please click here for more details>>> Return & Exchange Policy
4.2 ★★★★★
Based on 632 reviews
Sort
Product Reviews
★★★★★ 4
Works well
Size: 2 Tier,9.5''Wx10.5''Dx9.5''H
Decent quality. Fits well. A little flimsy but overall ok
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on May 18, 2026
★★★★★ 5
Versatile and Sturdy
Size: 2 Tier,5.5''Wx10.5''Dx9.5''H
I was able to store a lot of spices in a small space with a couple of these. While you can screw them into the cabinet, I set them on a nonskid shelf liner and so far, don't need to permanently install them with hardware. They're adjustable and sturdy.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on May 9, 2026
★★★★★ 5
Excellent
Size: 1 Tier,4.5''Wx10.5''Dx2.5''H, Size: 1 Tier,4.5''Wx10.5''Dx2.5''H
Glad I purchased them made my spice drawer so organize love them!!!
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on March 31, 2026
★★★★★ 5
Great racks!
Size: 2 Tier,7.5''Wx10.5''Dx9.5''H
Great spice racks! Easy to assemble and easy to install. Racks are very sturdy and well made.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on March 7, 2026
★★★★★ 5
Perfect
Size: 2 Tier,5.5''Wx10.5''Dx9.5''H
Absolutely perfect not to big fit perfectly where my daughter wanted it.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on May 31, 2026




